Message Boards


All times are UTC - 5 hours




 [ 12 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Cannot patch Dotfuscator CE
PostPosted: Fri Mar 18, 2011 5:34 am 

Joined: Thu Mar 17, 2011 5:35 pm
Posts: 1

Hi

I have Visual Studio 2010 Edition of Dotfuscator CE (Version 5.0.2500.0) and have downloaded the patches from here (DotfuscatorCE5Patch5.0.2600.msp and DotfuscatorCE5Patch5.0.2601.msp)

Neither of these patches will apply though. I get an error message:

Quote:
The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing or the upgrade patch may update a different version of the program


This is on WinXP x86 SP3 and Win 7 SP1 x64. Both installations of Visual Studio are patched with Service Pack 1.

Is there another patch that I need to apply first?

Many thanks.



[Edit - Resolved]
I have a workaround:

Reinstall VS2010 in a XPx86 VM, patch, then copy the patched files out. Urgh.



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Fri Mar 18, 2011 10:38 am 

it seems like our patch installers are not correctly detecting the installation of CE5 build 2500 (which is included in VS 2010 SP1). I am forwarding this issue to our setup team and we should have fixed patches available soon. Sorry for the headache!



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Wed Mar 30, 2011 10:11 am 

Joined: Tue Mar 29, 2011 10:38 am
Posts: 3

I have exact the same problem here.
So, we have to wait for a new patch?

Spiny wrote:
Hi

I have Visual Studio 2010 Edition of Dotfuscator CE (Version 5.0.2500.0) and have downloaded the patches from here (DotfuscatorCE5Patch5.0.2600.msp and DotfuscatorCE5Patch5.0.2601.msp)

Neither of these patches will apply though. I get an error message:

Quote:
The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing or the upgrade patch may update a different version of the program


This is on WinXP x86 SP3 and Win 7 SP1 x64. Both installations of Visual Studio are patched with Service Pack 1.

Is there another patch that I need to apply first?

Many thanks.



[Edit - Resolved]
I have a workaround:

Reinstall VS2010 in a XPx86 VM, patch, then copy the patched files out. Urgh.



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Wed Mar 30, 2011 10:41 am 

We will have an updated patch available for download soon. However, as a workaround, you can manually extract the contents of the .msp file and replace your existing Dotfuscator CE program files as detailed below. However this is not recommended for most users, and is not officially supported.

Unpack the .msp using 7-zip. Among the output files, locate the CAB containing the updated Dotfuscator files. 7-zip does not append the extension (.cab) to this file, but this will typically be the largest file, and should have "CAB" in its name (ie., PCW_CAB_DfCE5_1). Unpack this file using 7-zip. You'll now have to rename the resulting files to match the names of the original files in your Dotfuscator CE install directory (%vsinstalldir%\PreEmptive Solutions\Dotfuscator Community Edition), which if you examine what is already in the install directory should be relatively obvious (ie., DfguiDll = dfgui.dll, DfPreattributesDll = PreEmptive.Attributes.dll). Overwrite the existing files with the new ones from the patch and you should be ready to go.



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Wed May 18, 2011 10:08 am 

Joined: Tue Mar 29, 2011 7:00 am
Posts: 1

I have the same problem. Are we still waiting for this 'soon to come' patch?



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Tue May 24, 2011 3:58 pm 

Joined: Tue May 24, 2011 1:56 pm
Posts: 1

Any news? I'm waiting on this too.



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Mon May 30, 2011 6:00 am 

Joined: Mon May 30, 2011 5:38 am
Posts: 1

Waiting as well - I am unable to find the download link for this either.



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Thu Jun 30, 2011 10:18 pm 

Joined: Mon Sep 06, 2010 9:43 pm
Posts: 2

I uploaded a self-extractor RAR file (created with WinRAR)
http://www.mediafire.com/?s207x372xopvwo0
you can rename it to .rar if you want



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Tue Jul 05, 2011 8:01 am 

Joined: Tue Jul 05, 2011 5:42 am
Posts: 1

I've just spent six hours upgrading everything from VS 2005 to VS 2010. Four of those hours have been on Dotfuscator...

Thank goodness I found this thread as it has solved one of the problems very quickly. It seems very strange to me that after three months PreEmptive can't even provide an update on what for some users must be a blocking issue.

I'm happy to say that the instructions above re extracting the MSP and then the CAB do seem to work fine though - my Dotfuscator is now running perfectly from the command line. The only discrepancy seems to be that of course Control Panel still reports it as v5.0.2500. Hopefully they will be able to produce a new patch in due course.

At least with 5.0, since it runs from the command-line instead of within VS, I won't have to sift through over 300 non-suppressible nag messages (one per generic type or member in my code) telling me to buy Pro edition, every time I do a build :)



Top
  
 
 Post subject: Re: Cannot patch Dotfuscator CE
PostPosted: Wed Jul 27, 2011 3:35 pm 
PreEmptive Solutions

Joined: Mon May 17, 2010 12:07 pm
Posts: 9

New installers have been released for Dotfuscator CE5.0.2600 and CE5.0.2601 patches and are available under My Account -> Downloads section of our website. New installers should work correctly with Visual Studio 2010 SP1.



Top
  
 
Display posts from previous:  Sort by  
New Topic | Post Reply  [ 12 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron