Dotfuscator Professional Edition, Version 6.0.0-beta – Release Date December 19, 2019

Categories
Dotfuscator Pro Change Log

Published on December 19, 2019 by PreEmptive Admin

Reading Time: 3 minutes

Change Log – Version 6.0.0-beta – Release Date December 19, 2019

This is a beta release of Dotfuscator.
Please see the Beta Release Notes for important information.

This is a new major version of Dotfuscator Professional.
See Upgrading from Dotfuscator 4 for details on how to migrate from the previous version of Dotfuscator Professional to this version.

Important Compatibility Changes

  • Dotfuscator’s build components can now be installed on macOS and Linux.
    For example, you can protect a Xamarin.Android project when building it in Visual Studio for Mac.
    See macOS and Linux in the User Guide for more details.
  • Dotfuscator can now run under MSBuild engines for .NET Core and for Mono, in addition to the full .NET Framework MSBuild.
    This means that Dotfuscator-integrated projects can now build under the .NET Core dotnet command and the Mono msbuild command.

    IMPORTANT NOTE: For this beta release, .NET Core build environments must be using SDK version 3.0 or later.

  • Dotfuscator can now be installed with the PreEmptive.Protection.Dotfuscator.Pro NuGet package on Windows, macOS, and Linux.
    This package is distributed privately by PreEmptive to licensed Dotfuscator Professional users.

    • The Windows installer package (.msi) continues to be supported alongside the NuGet package.
      Windows users can choose to use either the Windows installer or the NuGet package to provision Dotfuscator.
  • The Visual Studio integrated UI has been removed.
    It is replaced with an MSBuild integration which supports Visual Studio, Visual Studio for Mac, Visual Studio Code, and command line build tools.
    We recommend migrating your Dotfuscator Projects (.dotfuproj files) to the new integration; see migration instructions for Visual Studio Integration for details.
  • The oldest supported version of Visual Studio is now 2012 (previously was 2010).
  • The minimum version of .NET Framework required to install Dotfuscator with the Windows installer is now 4.7.2 (previously was 4.6.1).
  • Dotfuscator no longer supports injecting PreEmptive Analytics runtime telemetry.
    Checks are still supported, and you can use custom code triggered via application notification to report security incidents to an analytics platform of your choosing.
  • Dotfuscator no longer supports assemblies built for Silverlight, Windows Phone, or WinRT (e.g., Windows 8 apps).
  • Dotfuscator no longer supports .appx files as input packages.
    To protect apps which are packaged into this format, such as Universal Windows Platform (UWP) apps, use the MSBuild integration, which will apply protection before the project’s packaging steps.
  • Dotfuscator no longer supports the Unity game engine.
  • Dotfuscator’s Authenticode signing feature has been removed; please use a post-build event or a custom step in your build system to sign your assemblies after Dotfuscator processes them.
    Dotfuscator can still re-apply strong name signing to your assemblies.
  • Dotfuscator no longer has its own proxy settings.
    Please use the system proxy settings instead.
  • Dotfuscator’s Check Attributes are now distributed separately from Dotfuscator.
    They are available in the PreEmptive.Protection.Checks.Attribute NuGet package on nuget.org.

Enhancements

  • Updated the product’s logos and branding.
  • Properties can now be defined in terms of other properties.
  • Improved Config Editor user experience.
  • Improved the stack trace translation tool and Lucidator to accommodate stack traces reported by Visual Studio App Center.
  • The SuppressIldasm feature now uses a .NET Standard version of the attribute, allowing the feature to work on assemblies not targeting the full .NET Framework.
  • Dotfuscator now recognizes the PREEMPTIVE_TELEMETRY_OPT_OUT environment variable to control customer feedback options.
  • This release may include protection enhancements not described here.

Functional Changes

  • Dotfuscator 6 can be installed side-by-side with Dotfuscator 4.
    However, only one version of Dotfuscator 6 can be installed at a time when using the Windows Installer.
    To have side-by-side installations of Dotfuscator 6, please use the NuGet package.

Fixes

  • Fixed an issue where changing the build configuration (e.g., “Release”) when using Automatic Input Management can cause configuration rules to be ignored.
  • Fixed an issue where an invalid license file causes the Config Editor to close with no error message.
  • Fixed an issue where adding a Check after building in the Config Editor can cause a crash.
  • Fixed an issue where a config file using Automatic Input Management could be treated as changed even when there are no changes.
  • Fixed an issue where the Config Editor incorrectly changes a config file to have Manual Input Management set.