Change Log - Version 1.1.0

Features

  • pjsd-core
    • Now, protection supports the --es5 command-line option that disables using obfuscation features that require ES2015 (or above) features. This switch is useful when the app runs in Internet Explorer.
    • ProtectionManager support obtaining summary information about the protection process
    • LocalDeclarationTransform checks if the source code contains any eval function calls (unsafe construct)
    • LocalDeclarationTransform checks if the source code contains any with JavaScript statement (unsafe construct)
    • StringLiteralTransform now handles ES2015 templated string literals
    • Control flow transformation optimizes break, continue, return statements and state changes
  • pjsd-core, pjsd-metro-plugin, pjsd-webpack-plugin
    • Typings are distributed alongside the packages to make them easier to consume